Minimum supported OS is now 4.5
Note: This only affects the pre-2.0 version (known as 1.9.x, or the development builds)'
As of the latest development build (184.108.40.206), the oldest version of BlackBerry OS supported by LogicMail is now 4.5. (It had previously been 4.2.) If you are one of the very few people still running an older BlackBerry with OS 4.2 or 4.3, please try to upgrade to 4.5.
Here are the reasons I made this decision:
- The official BlackBerry development tools (i.e. the Eclipse plug-in) does not support anything older than OS 4.5 on a new installation
- I only have OS 4.2/4.3 on my systems because I have older installs that I've updated.
- It only pretended to support OS 4.2 and 4.3 in the past. I could build, but the simulators never worked right, so I never tested on anything older than 4.5 anyways.
- This is an annoying dependency issue to figure out for a new developer freshly checking out the source code to LogicMail.
- OS 4.5 cleaned up some API calls for device/network information that look very kludgy on OS 4.2. (technically 4.3 fixed some of these)
- Pretty much all OS 4.2/4.3 devices are upgradable to OS 4.5.
- Download statistics show that hardly anyone is using anything older than OS 4.5 anymore.
So I've already done the following:
- Modified the automated build files to change the base OS to 4.5 (Ant build.xml and project.properties files)
- Modified the Eclipse projects to that used to have a 4.2.1 dependency to now have a 4.5.0 dependency (LogicMail, LogicMailTests, J2MEUnit).
- Reconfigured the build server to generate 4.5.0 instead of 4.2.1.
I'm now in the process of upgrading my oldest physical test device (an 8820) to OS 4.5. Over the next several days I'll be renaming any source files ending in "BB42", and trying to clean up my use of APIs marked as deprecated in 4.5.