Help (#2) - No Attachment (#122) - Message List

No Attachment

Hi

When I try to attach files, it says attached but when the mail is sent the attachment is not received by the recipient. Also when downloading attachments anything over 100kb does not seem to work.

Does anyone else have this issue? I am ussing a bold 9700

  • Message #364

    Large attachments have not been that well tested yet. But I do want to try testing the same thing you are, to see what results I get.

    For sending, I want to know the following:

    • What type of file are you attaching?
    • How many files are you attaching?
    • How big are these files?

    For receiving, I'd like to know the following:

    • Is this IMAP or POP? (if POP, ignore the rest of the questions)
    • What sizes have you tested? Is 100kb a mostly hard-limit, or a ballpark number? (i.e. can I reproduce the issue with a 150kb attachment, or do I need to go bigger?)
    • What e-mail client was the message originally sent with, if you know?
    • What does the structure of the message look like? (the "Properties" page, accessible from the menu when viewing a message, will tell you)

    And in general...

    • Are you connecting via WiFi or the mobile network? If you can test both, do you get different results depending on which you use?
    • If this mostly happens on the mobile network...
      • What kind of mobile network? (i.e. the connection type for the phone, "EDGE", "3G", "1xRTT", etc)
      • Do you have any idea which connection method LogicMail is using? (i.e. Direct TCP /w APN, WAP2, MDS, etc) If you enable debug-level logging, as briefly described on the debugging page, and have it show messages from "LogicMail", "net.rim.tcp", and "net.rim.networkapi" (on OS 5.0+), the log message should either tell you, or have enough info that I could figure it out from them.
    • Message #365

      Sorry about the delay was out of town. Sounds good I will be happy to help test this for you :)

      Sending -

      1. I have tried Excel and Word but they show as attached in the email but are not sent
      1. Only one file at a time
      1. The excel was 18kb and the document was 88kb

      Receiving

      1. Using IMAP
      1. You should be able to recreate the issue with a 150kb file, I have tried a number of files though I cant recall specifics (Can test if you need me to) and 100kb is a ball park figure but anything below should work while anything over should fail
      1. Not sure about the email client but if you like we can test this as well, but I am not sure how the client would effect?
      1. Structure is as follows -
        - multipart/mixed
          - multipart/alternative
              text/plain(1k)
              text/html(5k)
              application/pdf(578k)
        

      General -

      1. It happens on both WIFI and Mobile Network. It happens on 3G as well as GSM
      1. Debug said "field full" when I pasted it, just so you know. (Also dont see any sensitive data but if there is please remove this from public forum and let me know so I can change password etc)
        #BlackBerry Event Log (cpt)
        #HwID: 0x4001507
        #DPIN: 0x21ce9c3e
        #PVer: 5.1.0.121
        #AVer: 5.0.0.442
        i LogicMail - Connection closed - 7/20 23:52:33
        d LogicMail - ImapProtocol.executeLogout() - 7/20 23:52:33
        d LogicMail - ImapProtocol.executeIdleDone() - 7/20 23:52:32
        d LogicMail - [RECV] * OK Still here - 7/20 23:52:20
        d LogicMail - [RECV] + idling - 7/20 23:52:10
        d LogicMail - [SEND CMD] A7 IDLE - 7/20 23:52:09
        d LogicMail - ImapProtocol.executeIdle() - 7/20 23:52:09
        d LogicMail - [RECV] A6 OK Fetch completed. - 7/20 23:52:05
        d LogicMail - [RECV] ) - 7/20 23:52:05
        d LogicMail - [RECV] CnN0YXJ0eHJlZgo0MzAxMTQKJSVFT0YK - 7/20 23:52:05
        d LogicMail - [RECV]
        MTZGMUFENTI3OTQyNDc3RTcxPjxBMTFFRUNENjYzQjZBODE2RjFBRDUyNzk0MjQ3N0U3MT5dCj4+
        - 7/20 23:52:05
        d LogicMail - [RECV]
        PDwgL1NpemUgMTIyIC9Sb290IDEgMCBSIC9JbmZvIDIgMCBSCi9JRCBbPEExMUVFQ0Q2NjNCNkE4
        - 7/20 23:52:05
        . . . snip . . .
        
      • Message #387

        Just one thing... so if the attachment is bigger that 150Kb you won't receive it? I do not get attachment (DOC) that is 29Kb... and I've set the dl for the message to 5000Kb.

      • Message #366

        First, I reformatting your reply using WikiFormatting so it would display correctly here. Second, I snipped out the excess raw base64 log data. The log really does look a lot more readable, and a lot less like a "random hunk of gobbledegook" once snipped and formatted that way.

        But, that being said, the log doesn't really show that much. If your original log included something before the "big hung 'o base64", reporting with that bit snipped could help a little. Likewise, just logging without connection debugging could also be useful.

        However, all this log snippet really shows is that a fetch of binary data completed successfully, and then you logged out. If this fetch was of an attachment, then it means the issue is in the saving process. I'll have to do more testing and report back. Issues with large files may be unavoidable in the short term, and some issues might be unavoidable in the long term as well (only IMAP lets me download in segments, for example). Though regardless, files in the 100-200kb range really shouldn't have issues.

        • Message #367

          I didnt leave anything out, I followed the steps as said on your site and pasted the entire response which I got.

          Is it only me who is having this issue? anything else I can do to assist?

          • Message #392

            Hey Steve,

            I am having the same type of issues. It is not just you. My logicmail version is 1.9.1.208 and I am using a BlackBerry Curve 8530 on a Cricket 1xev network. It is using wap2 talking to my OSX imap server. I can send and receive mails just fine normally. When I attach a 15KB xls file it has the little paperclip icon when it is in my outbox but the attachment is not there when it arrives back to me.

            My attempt to answer the questions..

            .xls 97-2004 format from Sheet To Go program. just one xls file stored on my sd card. 15KB. I haven't tried opening a large attachment yet. I just finished testing over wifi and it also failed to include attachment. wifi and 1xev using wap2.

            Thanks in advance for any help.

            Hey I came back to edit this post because in the last few days someone has opened a ticket for this with a possible workaround.

             http://www.logicprobe.org/proj/logicmail/ticket/228

Subscriptions

Moderation