Open Discussion (#3) - Mime format on forward - can'r read (#191) - Message List

Mime format on forward - can'r read

Whenever i forard an email message using logical mail, it gets sent in Mime format and my wife who is using Outlook, cannot read it:

MIME-Version: 1.0 Content-Type: text/plain;

charset=utf-8

Content-Transfer-Encoding: base64

RXh0cmEgam9ibGVzcyBhaWQgaXMgY3V0IGluIE1hc3MuCgpUaG91c2FuZHMgdG8gbG9zZSBVUyBi ZW5lZml0cyBhcyBlY29ub215IHBpY2tzIHVwCgpCeSBLYWl2YW4gTWFuZ291

Is there a workaround for this? Also, is there any way to edit an forwarded email before sending it?

James

  • Message #552

    You can always edit an e-mail when forwarding it, since LogicMail currently implements forwarding by putting the content of the original message in the body of a new message.

    Are you using POP or IMAP?

    What kind of messages are you trying to forward? Is there any chance you can send me the raw source (i.e. what "View->Message Source" shows in Thunderbird, or by forwarding as an attachment with a desktop client that supports it) of one of these messages, or otherwise have one sent directly to me?

    Finally, what language are these messages written in?

    • Message #553

      I am using IMAP connecting to gmail using English.

      Forwarding TEXT messages works as expected. You can edit them withing the forward message before sending and the receiver gets them fine.

      When I create either a HTML or Rich Text message (via Outlook) and send it to an Outlook client using LogicMail, the receiver gets an email with the text formatting removed and a winmail.dat file attached to the email. The email message in Gmail shows the same thing - no formatting, winmail.dat attached.

      If I create a HTML message using gmail web, Logicmail displays the formatting OK but when i try to forward that message along, in the forward screen, the original message does not have the text in it, only the following:

      ----Original Message----
      Subject: from gmail in html format
      Date: Wed, 22 Jun 2011 21:53:30 -0400
      From: "James Mikelis" <xxx@gmail.com>
      To: "A_James (gmail)" <xxx@gmail.com>
      ------------------------
      

      and the receiver only gets the above, without the HTML line in it. The following is the original message (but won't show the font formatting since i can't show that here)

      From: James Mikelis [mailto:xxx@gmail.com]
      Sent: Wednesday, June 22, 2011 9:54 PM
      To: A_James (gmail)
      Subject: from gmail in html format
      This is HTML created in gmail web.
      

      I haven't been able to recreate the MIME issue but when the correct condition happens, I will make a note and post it here.

      • Message #554

        (I edited your reply to include the WikiFormatting marks so the text sample would look right.)

        You appear to be running into two issues:

        1. LogicMail does not support quoting HTML content in a reply/forward
          • This is not easy to fix, but eventually I'll need a workaround for people who preference HTML message display. (normally, if you preference HTML display, it doesn't even load the text/plain version of a message)
          • For cases where the message only contains HTML content, I may need some sort of hopefully-not-too-broken tag stripper. Currently, only in those cases, I quote the raw HTML verbatim.
        2. Almost nothing except MS Outlook understands  TNEF E-Mail content.
          • This is where your winmail.dat attachments come from.
          • There are web pages discussing how to disable TNEF in MS Outlook
          • 3rd party plugins/apps exist for some E-Mail clients that can decode TNEF
          • I'm not sure how hard it would be to build TNEF support into LogicMail, but its not going to be high priority unless it becomes a common issue
        • Message #555

          I was able to reproduce the MIME format issue.

          Go to  http://healthland.time.com/2011/06/23/study-the-best-and-worst-foods-for-weight-loss/ and copy the text. In logic mail, paste the text in a message and send it to your account. Then open the message it with logicmail and you should see the following:

          MIME-Version: 1.0
          Content-Type: text/plain;
             charset=utf-8
          Content-Transfer-Encoding: base64
          U3R1ZHk6IFRoZSBCZXN0IGFuZCBXb3JzdCBGb29kcyBmb3IgSGVhbHRoeSBXZWlnaHQKClBvc3Rl
          ZCBieSBTb3JhIFNvbmcgCgpKdW5lIDIzLCAyMDExIGF0IDg6MDEgYW0gCgpXaGVuIGl0IGNvbWVz
          IHRvIGtlZXBpbmcgeW91ciB3ZWlnaHQgZG93biwgYSBuZXcgc3R1ZHnCoGJ5IEhhcnZhcmQgcmVz
          ZWFyY2hlcnMgc3VnZ2VzdHMgdGhhdCB0aGUgcXVhbGl0eSBvZiB5b3VyIGZvb2QgbWF0dGVycyBt
          b3JlIHRoYW4gaXRzIGNhbG9yaWUgY291bnQuCgpJbnR1aXRpdmVseSwgd2Uga25vdyB0aGF0IGdv
          ---- additional text removed
          

          although....now i just tried it and it went through OK and was readable. argh. why does this work sometimes but not others?

          • Message #556

            Okay, I figured out the real problem here, and its no surprise that it doesn't happen to you all the time. See ticket #334 for details.

            Let's just say its a combination of "user error" and "application lets the user make that error".

            • Message #557

              Ticket #334 says "Implement network stall detector". I don't understand how this relates to the MIME issue.

              James

              • Message #558

                Because it was really ticket #344, and I made a typo :-)

Subscriptions

Moderation