Ticket #58 (closed Bugs: invalid)

Opened 11 years ago

Last modified 11 years ago

CC Build 38: Sending email not properly authenticating? (SMTPSA)

Reported by: tengel Owned by:
Priority: minor Milestone:
Component: LogicMail Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

Running the latest build (CC build #38) on a BB 8320 with T-Mobile, BIS, and APN properly configured. Before installing this build the previous was removed to avoid any settings changes in the data structure (Identities et. al).

This has been non-operational for awhile, first chance I've had to debug it - it doesn't appear that SMTPSA is working properly. I have LogicMail set up with my mail server in SSL mode port 465, PLAIN login, not using MDS proxy. Upon logging in (IMAPS) to the Inbox then selecting Compose E-mail, then Send I get 'Connecting to server', 'Sending message', then right away 'Error with recipient' on the handheld.

On my mail server (I'm the company IT magicman) the logfile properly indicates:

2008-02-04 16:36:51 H=m750e36d0.tmodns.net (localhost) [208.54.14.117] F=<tengel@…> rejected RCPT <tengel@…>: rejected 208.54.14.117 in blacklist at sbl-xbl.spamhaus.org

This, however, should not happen with a properly authenticated SMTP + SSL + Authentication (SMTPSA) oriented session; incoming mail on our server that is sent with SMTPSA is *not* sent through blacklist checks (or SpamAssassin checks) because we know it's trusted non-spam. Unfortunately I'm at a loss as to how to help debug this further without impacting the network (i.e. putting our MTA into debug mode) on the server side.

Auth mode was tested with PLAIN and LOGIN, same results. CRAM-MD5 is not supported on the server side, and I can verify 101% that SMTPSA works with this server (many remote people using it). The SSL certificate is the same one as the IMAP server (same machine), and it's a CAcert.org issued cert - the Root is properly installed on my BB device as well, I get no cert errors of any sort reported (i.e. during IMAP SSL login).

Willing to debug, lemme know what you need done.

Change History

comment:1 Changed 11 years ago by octo

If you turn on connection debugging inside LogicMail, you can have it log data being exchanged with the server. Since you are using SSL, this is really the only easy way to capture that information. Hopefully it'll help you find out exactly what is being sent to the SMTP server, and make it easier to figure out the issue.

comment:2 Changed 11 years ago by tengel

  • Status changed from new to closed
  • Resolution set to invalid

Thanks, I never knew this was here! By sheer luck of the draw the new test email went through so I could see the headers on the receiving side, and it is in fact properly using esmtpsa, so the problem is somewhere else. Closing this bug.

Note: See TracTickets for help on using tickets.